X request 55.0 error BadDrawable with Citrix Receiver

Hi all. Got a tough one (or two).

I’ve been using Citrix Receiver 13.9.1 to logon to my work’s software successfully without problems remotely from home for at least a year. All of a sudden, I’m getting a "the x request 55.0 caused error: "9:BadDrawable (invalid Pixmap or Window parameter) and the program won’t load. This error is on Budgie and, for kicks, I tried it on Kubuntu 18.04 with its qt system without a change. I’ve used Nouveau and NVIDIA drivers without change. About 1 time of 30 attempts, it’ll load, otherwise, it won’t. My hospital says they’ve made zero changes on their end, which I can believe, and their only advice was “switch to Windows.” I’d really NOT want to do that. Interestingly, I can run the Receiver fine using the Citrix Chrome extension on Chrome for Linux, but this is really suboptimal and hacky.

So, two questions.

  1. Is anyone familiar with the above error? The only fix I found online was for a different software package, but that fix involved editing the xorg.config file, and that doesn’t exist anymore…

  2. [SOLVED, see below] If I can’t find a fix, I’ll need to do use the hacky Citrix Chrome extension to launch the Citrix .ica files. However, that Chrome extension doesn’t show up as an option in the apps when I want to change a file association in Budgie. The path and command for the extension is:

/opt/google/chrome-beta/google-chrome-beta --user-data-dir=/home/[home]/.config/google-chrome-beta --profile-directory=Default --app-id=haiffjcadagjlijoggckpgfnoeiflnem

But how with Budgie do I set the default to use that string for launching a certain file type?


Edit: Should I try Ubuntu Gnome with Wayland?

SOLVED Q2: Ok, to launch a file with an app not listed in the window listing apps that Budgie brings up, just paste the full string into the search bar on top, which will do more than search but actually launch the file with the string that’s pasted in. After that, when launching the file and choosing the app a second time, it will list the string used as an option (like of like how it works in XFCE, but not explicitly saying so). Just an FYI for anyone with that problem…

Sorry - not really familiar with this. I’ve just read probably the same things as you will have researched - change the colour depth seems to be a favourite solution.

I would hazard a guess the experts here would be the citrix support forum.