Bug in ShowTime Applet in 19.04 Preview

I have noticed the following bugs in the ShowTime Applet. I’m fully updated as of today at 3:00pm EST on 3/16/19. The ShowTime applet often appears in unexpected places when I first login to the Budgie Desktop. The screenshot below illustrate this behavior. Sometimes the ShowTime will even show up on the lower screen of the dual monitor arrangement that you see even though I don’t have this set as the primary monitor.


When I open “Budgie Desktop Settings” app then ShowTime goes to the expected location on the screen.

Finally, when I go to edit the settings of the ShowTime applet all of the settings are “grayed out” and I’m unable to change any of the settings.

I know there are still lots of changes coming before the release of 19.04, but I thought I would make you aware of this issue. Let me know if you would prefer this bug report in a different location or if I can do either additional testing or give additional information. I have additional screenshots to illustrate these issues, but as a new user on the forum I was only allowed to attach one. Thanks to the whole team for all of your efforts to make a great distro.

We had a thought here. Can you temporarily unplug your second monitor and see if the issue still happens? Then we can try to determine if this is related to dual monitors, or an issue across single as well.

Thank you.

I have tried unplugging the second monitor that I use as my primary and tried logging out and in 3 times and ShowTime always appeared in the same place as noted in the screenshot below. It also remains in that position when “Budgie Desktop Settings” opens unlike when I opened “Budgie Desktop Settings” with the dual monitors and ShowTime would suddenly jump to the expected spot on the screen. I kind of feel like the position is a little off, not quit into the lower right hand corner of the screen to my eyes.


I still have the issue of the “grayed-out” settings for ShowTime making it impossible to change any of the settings for the applet.

Thank you for getting back to us. We will have a look once @vlijm is available for discussion.

On the phone atm, but could you post the output of xrandr command (with 2nd screen attached)? and is the position set to auto? Will ask you a few gsettings outputs tomorrow if that is all right with you. Thanks for posting!

…at the same time: if all is greyed out, that is the state (deliberately) when draggable is on. Did you by any chance forget to tick “save”?

Here is the output of xrandr =
mowest@C650:~$ xrandr
Screen 0: minimum 320 x 200, current 1680 x 1818, maximum 8192 x 8192
LVDS-1 connected 1366x768+0+1050 (normal left inverted right x axis y axis) 344mm x 193mm
1366x768 60.00*+
1360x768 59.80 59.96
1280x720 60.00 59.99 59.86 59.74
1024x768 60.04 60.00
960x720 60.00
928x696 60.05
896x672 60.01
1024x576 59.95 59.96 59.90 59.82
960x600 59.93 60.00
960x540 59.96 59.99 59.63 59.82
800x600 60.00 60.32 56.25
840x525 60.01 59.88
864x486 59.92 59.57
800x512 60.17
700x525 59.98
800x450 59.95 59.82
640x512 60.02
720x450 59.89
700x450 59.96 59.88
640x480 60.00 59.94
720x405 59.51 58.99
684x384 59.88 59.85
680x384 59.80 59.96
640x400 59.88 59.98
576x432 60.06
640x360 59.86 59.83 59.84 59.32
512x384 60.00
512x288 60.00 59.92
480x270 59.63 59.82
400x300 60.32 56.34
432x243 59.92 59.57
320x240 60.05
360x202 59.51 59.13
320x180 59.84 59.32
VGA-1 connected primary 1680x1050+0+0 (normal left inverted right x axis y axis) 473mm x 296mm
1680x1050 59.95 +
1600x1200 60.00
1280x1024 75.02 60.02
1440x900 74.98 59.89
1280x800 59.81
1152x864 75.00
1024x768 75.03 70.07 60.00
832x624 74.55
800x600 72.19 75.00 60.32 56.25
640x480 75.00 72.81 66.67 59.94
720x400 70.08
1680x1050_60.00 59.95*

All the settings are “grayed out” when I first open “Budgie Desktop Settings”. I can’t uncheck “Automatic” or change the Time font, size & color or any of the other settings. So I can’t even change the position of ShowTime and click on “Save position”. The settings were all “grayed out” when I disconnected the external screen too. Hopefully this shows in the screenshot below:

Here is how ShowTime looked when I logged in this time with the external screen attached and set as the primary display:

I have the feeling your dconf path is messed up, possibly the remains of an error before you updated to the latest showtime version. Apparently your showtime window is draggable currently. Could you close the settings window, run dconf reset -f /org/ubuntubudgie/plugins/budgie-showtime/, then log out/in again and see what happens.

I ran that command, and that fixed the “grayed out” options. Also did some tests, logging out, restarting, shutting down, and ShowTime seems to stay in the same place now.

I’m curious of what the “four corner” checkbox is supposed to do, because on my system that setting does not seem to do anything. When Automatic is checked it always puts the time on the Primary screen in the lower right corner, and those check boxes are “grayed out”. When I uncheck “Automatic” then I can select those check boxes, but ShowTime doesn’t move, and when I drag to place ShowTime it only stays where I had saved the position to the last time. Are those checkboxes for a different placement setting that isn’t quit done yet?

The checkboxes define the anchor of the showtime desktop window. Many times, you won’t notice the difference, until the length of the time or date string changes (whichever is the longest). Then the box will expand in the direction, opposite to the anchor, while the windowcorner is pinned at the anchor.

Think of the anchor as the punaise you pin a note to the wall with. Note also the difference when playing with the line distance and pick an anchor at top or bottom.

With autoposition on, the time window is pinned to the right/bottom of the primary monitor, anchor SE.

@mowest - All good now? If so We can mark that command as the solution. Have a good one.