[Solved] Can't access my desktop

IMG_20180816_205108
So. Today I was trying to use my computer and found this.
When i tip the right password, the screen blacks out and goes back to that screen.

What version if the operating system are you using?

Switch to a tty and make sure you are fully up to date

Failed to start session?

I’m not sure. I have downloaded it last month from the oficial page.

Switch to a what?
I saw the link and I don’t remember deletting anything.
I have pasted some data in a partition of the disk that contained some Windows archives.

Press ctrl+alt+f3

Then login using you username and password

Type

uname -a

What is the output ?

Type each of those commands I gave you I that link.

What is the output?

Ctrl+alt+f7 to switch back to a graphical login and try logging in again

How exactly did you do that ? Maybe have you moved some other files needed for starting your budgie-desktop ?

Some readings : What is a ttyterminalcommand line

Nothing happens.

Where?

I’ve cutted it from a removable hard drive. I don’t remember touching anything related to the files needed for starting my budgie desktop.

pressing CTRL+ALT+F1 to F7 will always change the TTY - 1 to 6 will be text based. TTY will change the to the graphical login screen.

Hold down CTRL - then whilst holding down CTRL - hold down ALT - and whilst still holding both CTRL and ALT Press your F3 key.

The only shortcut that seems to work is ctrl + alt + f5.
When i’m there, I try to log in and the answer is this:
IMG_20180823_010521
Then, ctrl + alt + f7 doesn’t do anything.

Since you cannot log in using your normal account you will need to reset your password

Please follow this advice on how to do this

@Luncheon_Ticket hoping it’s not too late

« Félix » as a login name may look strange.

Don’t misread me, it’s a nice name but login names are usually only lowcase and without accents.

Did you try with « felix » ?

@fossfreedom well no reproach as it can be helpful but resetting password should remain a kind of last survival emergency kit, lol.

Good spot! I didn’t notice the username but was concentrating on the fact that the OP couldn’t login.

The name with the uppercase and acent used to work.
When I try with felix this is what appears:
IMG_20180823_201022
Didn’t try that. Thanks Coeur.
In the last line it says in spanish that it cannot create a temporal file because of a lack of sapace in the device.

Does it sound possible that your disc, or that partition of disc, is « full » ?

df -h
will show storage capacity of your partitions.

ncdu
is a simple tool to check your disk usage ( use ←↑↓→ keys to browse ) and eventually delete files and folders ( hit d key as delete and ? for help ).
To install it
sudo apt install ncdu

Often culprits for disk usage are old linux kernels.

sudo apt autoremove --purge
may free some space by deleting unused packages, including older unused kernels from automatic updates ( not the manually installed ones ).
And also
sudo apt autoclean
by cleaning local indexes of no longer useful downloaded packages ( my pity translation sorry )

Anyway I am not sure a full disk explains why you can’t acces your desktop.

It’s quite possible.
IMG_20180823_225910
I think it’s jus showing the partition it made for Budgie when I installed it. I left 100gb or so for the OS to use.
Installed ncdu, ran the autoclean successfully, the - - purge command gave me this answer:
IMG_20180823_232157
I’m also not sure if the full partition is the problem. But my current password seems to work well.
Also. How do I turn off the computer with a command? Last time I tried holdin the buttom it turned off very abruptly. I don’t know if it’s good for the pc.

yeah - 100% will cause issues such as not being able to login.

The command is

sudo apt autoremove --purge

there is NOT a space between the dashes (–)

To shutdown from the command line

sudo shutdown now

To reboot from the command line

sudo reboot --

After running the autoremove how much space have you freed?

dh -h

IMG_20180824_173314
On the last line it says something like:
E: purge package couldn’t be found.
Thanks by the way.

There should not be a space between --purge

sudo apt autoremove --purge

Another typo.

No space after the two - it’s –purge and not – purge as shown on your picture.

( well true that the font or its spacing on this site is not perfect, two short - look as one long – in plain text and in code two - show a bit much space between them )

Wherever applicable, copy and paste are better for avoiding typo.

[ wouaouw, same answer at the same moment :wink: ]

1 Like

Yeah. At the first try I wrote it witout the space and it responded something like:
E: that line of order doesn’t make sense.
The second try I left a space to see if that worked.